[[email protected] ~]$ sudo yum install gem
[sudo] password for admin:
Loaded plugins: langpacks, refresh-packagekit
fedora/20/x86_64/metalink                                                                                |  20 kB  00:00:00
updates/20/x86_64/metalink                                                                               |  17 kB  00:00:00
updates                                                                                                  | 4.6 kB  00:00:00
updates/20/x86_64/primary_db   FAILED                                                        ]  0.6 B/s | 1.6 MB 2980:13:24 ETA
http://kdeforge.unl.edu/mirrors/fedora/linux/updates/20/x86_64/repodata/eef70dbd32c07a997e311fcfbd1408973bad10a91ff0ab4975da9d89ed5ee00d-primary.sqlite.bz2: [Errno 12] Timeout on http://kdeforge.unl.edu/mirrors/fedora/linux/updates/20/x86_64/repodata/eef70dbd32c07a997e311fcfbd1408973bad10a91ff0ab4975da9d89ed5ee00d-primary.sqlite.bz2: (28, 'Operation too slow. Less than 1000 bytes/sec transferred the last 30 seconds')
Trying other mirror.
updates/20/x86_64/primary_db                                                                             | 7.2 MB  00:01:23
(1/2): updates/20/x86_64/pkgtags                                                                         | 856 kB  00:00:08
(2/2): updates/20/x86_64/updateinfo                                                                      | 650 kB  00:00:10
Resolving Dependencies
--> Running transaction check
---> Package rubygems.noarch 0:2.1.11-115.fc20 will be installed
--> Processing Dependency: rubygem(rdoc) >= 4.0.0 for package: rubygems-2.1.11-115.fc20.noarch
--> Processing Dependency: rubygem(psych) >= 2.0.0 for package: rubygems-2.1.11-115.fc20.noarch
--> Processing Dependency: rubygem(io-console) >= 0.4.1 for package: rubygems-2.1.11-115.fc20.noarch
--> Processing Dependency: ruby(release) for package: rubygems-2.1.11-115.fc20.noarch
--> Processing Dependency: /usr/bin/ruby for package: rubygems-2.1.11-115.fc20.noarch
--> Running transaction check
---> Package ruby-libs.x86_64 0:2.0.0.353-16.fc20 will be installed
---> Package rubygem-io-console.x86_64 0:0.4.2-16.fc20 will be installed
---> Package rubygem-psych.x86_64 0:2.0.0-16.fc20 will be installed
--> Processing Dependency: libyaml-0.so.2()(64bit) for package: rubygem-psych-2.0.0-16.fc20.x86_64
---> Package rubygem-rdoc.noarch 0:4.0.1-2.fc20 will be installed
--> Processing Dependency: rubygem(json) < 2 for package: rubygem-rdoc-4.0.1-2.fc20.noarch
--> Processing Dependency: rubygem(json) >= 1.4 for package: rubygem-rdoc-4.0.1-2.fc20.noarch
--> Processing Dependency: ruby(irb) for package: rubygem-rdoc-4.0.1-2.fc20.noarch
---> Package rubypick.noarch 0:1.1.1-1.fc20 will be installed
--> Processing Dependency: ruby(runtime_executable) for package: rubypick-1.1.1-1.fc20.noarch
--> Running transaction check
---> Package libyaml.x86_64 0:0.1.4-5.fc20 will be installed
---> Package ruby.x86_64 0:2.0.0.353-16.fc20 will be installed
--> Processing Dependency: rubygem(bigdecimal) >= 1.2.0 for package: ruby-2.0.0.353-16.fc20.x86_64
---> Package ruby-irb.noarch 0:2.0.0.353-16.fc20 will be installed
---> Package rubygem-json.x86_64 0:1.7.7-101.fc20 will be installed
--> Running transaction check
---> Package rubygem-bigdecimal.x86_64 0:1.2.0-16.fc20 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================================================================
 Package                             Arch                    Version                             Repository                Size
================================================================================================================================
Installing:
 rubygems                            noarch                  2.1.11-115.fc20                     updates                  224 k
Installing for dependencies:
 libyaml                             x86_64                  0.1.4-5.fc20                        fedora                    54 k
 ruby                                x86_64                  2.0.0.353-16.fc20                   updates                   65 k
 ruby-irb                            noarch                  2.0.0.353-16.fc20                   updates                   86 k
 ruby-libs                           x86_64                  2.0.0.353-16.fc20                   updates                  2.8 M
 rubygem-bigdecimal                  x86_64                  1.2.0-16.fc20                       updates                   77 k
 rubygem-io-console                  x86_64                  0.4.2-16.fc20                       updates                   48 k
 rubygem-json                        x86_64                  1.7.7-101.fc20                      fedora                    60 k
 rubygem-psych                       x86_64                  2.0.0-16.fc20                       updates                   75 k
 rubygem-rdoc                        noarch                  4.0.1-2.fc20                        fedora                   288 k
 rubypick                            noarch                  1.1.1-1.fc20                        updates                  6.3 k

Transaction Summary
================================================================================================================================
Install  1 Package (+10 Dependent packages)

Total download size: 3.7 M
Installed size: 13 M
Is this ok [y/d/N]: y
Downloading packages:
(1/11): libyaml-0.1.4-5.fc20.x86_64.rpm                                                                  |  54 kB  00:00:02
(2/11): rubygem-io-console-0.4.2-16.fc20.x86_64.rpm                                                      |  48 kB  00:00:01
(3/11): rubygem-json-1.7.7-101.fc20.x86_64.rpm                                                           |  60 kB  00:00:00
(4/11): ruby-irb-2.0.0.353-16.fc20.noarch.rpm                                                            |  86 kB  00:00:05
(5/11): rubygem-psych-2.0.0-16.fc20.x86_64.rpm                                                           |  75 kB  00:00:01
(6/11): rubygem-rdoc-4.0.1-2.fc20.noarch.rpm                                                             | 288 kB  00:00:00
(7/11): rubypick-1.1.1-1.fc20.noarch.rpm                                                                 | 6.3 kB  00:00:00
(8/11): rubygem-bigdecimal-1.2.0-16.fc20.x86_64.rpm                                                      |  77 kB  00:00:08
(9/11): rubygems-2.1.11-115.fc20.noarch.rpm                                                              | 224 kB  00:00:04
(10/11): ruby-libs-2.0.0.353-16.fc20.x86_64.rpm                                                          | 2.8 MB  00:00:10
(11/11): ruby-2.0.0.353-16.fc20.x86_64.rpm                                                               |  65 kB  00:00:13
--------------------------------------------------------------------------------------------------------------------------------
Total                                                                                           266 kB/s | 3.7 MB  00:00:14
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Installing : ruby-libs-2.0.0.353-16.fc20.x86_64                                                                          1/11
  Installing : libyaml-0.1.4-5.fc20.x86_64                                                                                 2/11
  Installing : rubygem-io-console-0.4.2-16.fc20.x86_64                                                                     3/11
  Installing : rubygem-bigdecimal-1.2.0-16.fc20.x86_64                                                                     4/11
  Installing : rubygem-json-1.7.7-101.fc20.x86_64                                                                          5/11
  Installing : rubygem-rdoc-4.0.1-2.fc20.noarch                                                                            6/11
  Installing : ruby-irb-2.0.0.353-16.fc20.noarch                                                                           7/11
  Installing : rubypick-1.1.1-1.fc20.noarch                                                                                8/11
  Installing : ruby-2.0.0.353-16.fc20.x86_64                                                                               9/11
  Installing : rubygems-2.1.11-115.fc20.noarch                                                                            10/11
  Installing : rubygem-psych-2.0.0-16.fc20.x86_64                                                                         11/11
  Verifying  : libyaml-0.1.4-5.fc20.x86_64                                                                                 1/11
  Verifying  : rubygem-io-console-0.4.2-16.fc20.x86_64                                                                     2/11
  Verifying  : rubygem-rdoc-4.0.1-2.fc20.noarch                                                                            3/11
  Verifying  : rubygem-bigdecimal-1.2.0-16.fc20.x86_64                                                                     4/11
  Verifying  : ruby-libs-2.0.0.353-16.fc20.x86_64                                                                          5/11
  Verifying  : rubygem-json-1.7.7-101.fc20.x86_64                                                                          6/11
  Verifying  : rubygem-psych-2.0.0-16.fc20.x86_64                                                                          7/11
  Verifying  : ruby-2.0.0.353-16.fc20.x86_64                                                                               8/11
  Verifying  : rubypick-1.1.1-1.fc20.noarch                                                                                9/11
  Verifying  : rubygems-2.1.11-115.fc20.noarch                                                                            10/11
  Verifying  : ruby-irb-2.0.0.353-16.fc20.noarch                                                                          11/11

Installed:
  rubygems.noarch 0:2.1.11-115.fc20

Dependency Installed:
  libyaml.x86_64 0:0.1.4-5.fc20          ruby.x86_64 0:2.0.0.353-16.fc20             ruby-irb.noarch 0:2.0.0.353-16.fc20
  ruby-libs.x86_64 0:2.0.0.353-16.fc20   rubygem-bigdecimal.x86_64 0:1.2.0-16.fc20   rubygem-io-console.x86_64 0:0.4.2-16.fc20
  rubygem-json.x86_64 0:1.7.7-101.fc20   rubygem-psych.x86_64 0:2.0.0-16.fc20        rubygem-rdoc.noarch 0:4.0.1-2.fc20
  rubypick.noarch 0:1.1.1-1.fc20

Complete!
[[email protected] ~]$
Topic revision: r1 - 2014.02.02 - PaulReiber
 
Copyright © is by author. All material on this collaboration platform is the property of its contributing author.